JBOSGi 2.5.0.Final for WildFly 10 Released!

I am pleased to announce the release of JBOSGi 2.5.0.Final for WildFly 10.

This release targets WildFly 10.0.0, and contains WildFly 10-related integration changes.

IMPORTANT: Since WildFly 10 has discontinued support for Java 7, JBOSGi has switched to and has been compiled with Java 8.

Release Notes – Version JBossOSGI 2.5.0

Enhancement

  • [JBOSGI-788] – Support WildFly 10 model
  • [JBOSGI-791] – Synchronize standalone config with 10 and exclude new batch subsystem

Feature Request

Task

  • [JBOSGI-769] – Reenable tests once WFLY on VFS > 3.2.9.Final
  • [JBOSGI-790] – Javadoc lint must be disabled everywhere

Getting the Overlay Patch or Installer

You can obtain JBOSGi 2.5.0.Final by a direct download via:

You can also get the same artifacts via Maven from JBoss Releases Repository:

[xml] <dependency>
<groupId>org.jboss.osgi.distribution</groupId>
<artifactId>jbosgi-distribution</artifactId>
<version>2.5.0.Final</version>
<classifier>installer</classifier>
<type>jar</type>
</dependency>
[/xml]

or

[xml] <dependency>
<groupId>org.jboss.osgi</groupId>
<artifactId>jbosgi-wildfly-build</artifactId>
<version>2.5.0.Final</version>
<classifier>patch</classifier>
<type>tar.gz</type>
</dependency>
[/xml]

or

[xml] <dependency>
<groupId>org.jboss.osgi</groupId>
<artifactId>jbosgi-wildfly-build</artifactId>
<version>2.5.0.Final</version>
<classifier>patch</classifier>
<type>zip</type>
</dependency>
[/xml]

Leave a Reply